Frequently Asked Question

Insecure Certificate Warnings on GENX Web Interface
Last Updated 2 years ago

There have been a number of 'standards' imposed over the last few years, each one promising better security and then subsequently being shown as weak or flawed leading to yet another standard. With each new standard both the server AND all the clients need to be upgraded so they can both understand each other. To make matters worse, some browsers are giving customers warning that their connection isn't secure when it is simply because we're using the most compatible standard rather than the very latest.

This is a catch 22 situation. Some customers running windows 10 or recently updated OS's are asking for the latest TLS1,4 standard, yet many of our linux clients and clients still using legacy systems such as XP won't be able to connect at all if we did that.

So, we're going to leave at TLS1.0 which is more than secure enough for its purpose and the most widely compatible, and encourage customers still using the GENZone webmail service with later operating systems such as Windows 8+, MacOS 10.10+, iOS 10+, Android 4+ to either:

Simply tell your browser to continue, or,
Use IMAP4 from a client, because it's faster, secure and an overall better solution, or if you must use a webmail service, request a free migration to the new GENX platform which is using TLS1.4 (from your account manager or Helpdesk).

Of course, We're fairly confident that TLS1.4 will be found to be flawed shortly and then we'll all be on TLS1.5 but that is the way of these things.

Please Wait!

Please wait... it will take a second!